同花顺公式全上全下型指标公式
01/26/2020

下面就是《同花顺全上全下型指标公式》的代码的,这是由股票公式指标网收集提供的,查看更多同花顺公式请你访问http://gupiao.qzjlw.com/category/thsgs/

DIFF=10*(EMA(CLOSE,4)-EMA(CLOSE,10))*4;DEA=1.3*EMA(DIFF,4);m=MA(CLOSE,2);A=MA(CLOSE,5);B=MA(CLOSE,10);D=MA(CLOSE,20);e=MA(CLOSE,30);F=MA(CLOSE,60);AAz=MAX(ABS(A-m),ABS(B-m));BBz=MAX(ABS(D-m),ABS(e-m));aaaz=IF(AAz>BBz,AAz,BBz);
bbbz=IF(aaaz>ABS(F-m),aaaz,ABS(F-m));
t:bbbz*4,colorred,LINETHICK1;
q:MA(t,2),colorcyan,LINETHICK1;
w:=diff,colorwhite,LINETHICK2;
r:=dea,LINETHICK1;
STICKLINE(CROSS(w,r),r-0.2,r-2,5),colorred;
STICKLINE(r>REF(r,1) AND t>REF(t,1) AND w>REF(w,1) AND q>REF(q,1) AND w>r AND t>q AND r>t AND w-r>REF(w-r,1) AND t-q>REF(t-q,1) AND
COUNT(r>REF(r,1) AND t>REF(t,1) AND w>REF(w,1) AND q>REF(q,1) AND w>r AND t>q AND r>t AND w-r>REF(w-r,1) AND t-q>REF(t-q,1),2)=1,0,-5,8),coloryellow;
up=IF(w>REF(w,1),REF(t,1)+ABS(t-REF(t,1)),REF(t,1)-ABS(t-REF(t,1)));
u=IF(w>REF(w,1),REF(up,1)+50*ABS(t-REF(t,1)),REF(up,1)-50*ABS(t-REF(t,1)));uu=MA(u,2);
p=2*MA((u+uu)/2,6)+30,colorred,LINETHICK3;
pp=MA(t,30),coloryellow;
ppp点=(t+q+w+r)/4,colorred;
pppp=EMA(ppp点-p,17),colorred;
PPP点MA6EMA10=EMA(MA(p,2),5),coloryellow,LINETHICK3;
S:=FROMNIGHT;
RSV=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
Ap=SMA(RSV,3,1);
Bp=SMA(Ap,3,1);
ep=3*Ap-2*Bp;
J=EMA(3*(ep-50),34),colorred;
J减pppp=EMA(J-pppp,4),colorred;
J减ppppma5=MA(J减pppp,5),colorlicyan;
Llp=MA(J减pppp,34),colorwhite;
A1:=2.5*(EMA(CLOSE,7)*350-EMA(CLOSE,21)*350);
B1:=EMA((0.668*REF(A1,1)+0.333*A1),1);
短多=IF(A1>=B1,A1,B1),LINETHICK2,colorlimagenta;
短空=IF(B1-A1,B1,A1),LINETHICK2,colorgreen;
火火火=(短多/3+短空/3+J减ppppma5+J减pppp+Llp),colorwhite,LINETHICK1;
火火火ma5=MA(火火火,5),colorblue;
STICKLINE((短多>火火火 AND 火火火>短空) OR (火火火>短多 AND 短多>火火火ma5),2,5,3);
STICKLINE(HHV(w,40)>REF(HHV(w,40),1),-5.5,-10,8),colormagenta;
w1:w/4;
r1:r/4;
STICKLINE(CROSS(w1,q),-w+3,w+1),LINETHICK3,colorlimagenta;
mk=(C+1.1*C)/2;
Ak=(SUM(C,4)+1.1*C)/5;
Bk=(SUM(C,9)+1.1*C)/10;
Dk=(SUM(C,19)+1.1*C)/20;
ek=(SUM(C,29)+1.1*C)/30;
Fk=(SUM(C,59)+1.1*C)/60;
AAzk=MAX(ABS(Ak-mk),ABS(Bk-mk));
BBzk=MAX(ABS(Dk-mk),ABS(ek-mk));
aaazk=IF(AAzk>BBzk,AAzk,BBzk);
bbbzk=IF(aaazk>ABS(Fk-mk),aaazk,ABS(Fk-mk));
tk:bbbzk*4,colorred,LINETHICK2;
qk:MA(tk,2),colorcyan,LINETHICK2;
Y:(2*1.1*C+3*EMA(C,4))/5*10-(2*1.1*C+9*EMA(C,10))/11*10;
STICKLINE(CROSS(y,qk),-w+5,w-3),coloryellow,LINETHICK4;

标签:

相关文章