通达信公式螺旋起爆主图指标公式
12/20/2018

下面就是《通达信螺旋起爆主图指标公式》的代码的,这是由股票公式指标网收集提供的,查看更多通达信公式请你访问http://gupiao.qzjlw.com/category/tdxgs/

P1:=7;
M1:=3;
M2:=6;
M3:=12;
M4:=24;
AAA:=CONST(HHV(H*0.5,90));
DIF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIF,9);
AAA2:=(DIF-DEA)*2*60;
启:=CROSS(AAA-REF(AAA,1),15);
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.02,'卖');
DRAWKLINE(H,O,L,C);
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.04) AND ((HIGH)/(CLOSE)0),91,0);
HIGHN:=8;
AA1:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BACKSET(AA1,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
DIF2:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA2:=EMA(DIF2,9);
AAA1:=(DIF2-DEA2)*2*60;
起爆:=CROSS(AAA1-REF(AAA1,1),15),COLORRED,LINETHICK2;
DRAWTEXT(起爆,L*0.99,' 起爆'),COLORYELLOW,LINETHICK2;
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.02,'卖');
DRAWKLINE(H,O,L,C);
买:=CROSS(AAA1-REF(AAA1,1),15),COLORRED,LINETHICK2;
DRAWTEXT(买,L*0.99,''),COLORYELLOW,LINETHICK2;
DRAWTEXT_FIX(1,0.21,0.1,0,DYBLOCK),COLOR0080FF;
DRAWTEXT_FIX(1,0,0.1,0,''), COLORYELLOW;
DRAWTEXT_FIX(1,0.12,0.1,0,HYBLOCK), COLORWHITE;
A1:=C>REF(C,4);
NT:=BARSLASTCOUNT(A1);
TJ11:=NT=9;
TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);
AY:=(BACKSET(TJ11>0,9) OR BACKSET(TJ13>0,NT))*NT;
DRAWTEXT(AY>0,H*1.02,VAR2STR(AY,0)),COLORFF00FF;
DRAWTEXT(NT=9,H*1.02,'9'),COLORGREEN;
B1:=CNT0:=BARSLASTCOUNT(B1);
DRAWTEXT(CROSS(ZIG(3,10),REF(ZIG(3,10),1)),LOW*0.98,' ') ,COLORMAGENTA;
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.02,'卖');
DRAWKLINE(H,O,L,C);
趋势线1:MA(CLOSE,P1),COLOR0000FF,LINETHICK6;
B2:=H/REF(C,1)>=1.041;
XG2:=B1 AND B2;
C1:=REF(C,4)/REF(C,5)>1.09 AND REF(C,4)=REF(H,4) AND REF(C,4)>REF(MA(C,5),4)
AND REF(O,4)>REF(MA(C,10),4) AND NOT(REF(C,2)/REF(C,1)>=1.09 AND REF(C,3)/REF(C,2)>=1.09);
C2:=H/REF(C,1)>=1.041;
C3:=REF(C,4)/O>1.02;
XG3:=C1 AND C2 AND C3;
D1:=REF(C,5)/REF(C,6)>1.09 AND REF(C,5)=REF(H,5) AND REF(C,5)>REF(MA(C,5),5)
AND REF(O,5)>REF(MA(C,10),5);
D2:=H/REF(C,1)>=1.041;
XG4:=D1 AND D2;
E1:=REF(C,6)/REF(C,7)>1.09 AND REF(C,6)=REF(H,6) AND REF(C,6)>REF(MA(C,5),6)
AND REF(O,6)>REF(MA(C,10),6);
E2:=H/REF(C,1)>=1.041;
XG5:=E1 AND E2;
F1:=REF(C,7)/REF(C,7)>1.09 AND REF(C,7)=REF(H,7) AND REF(C,7)>REF(MA(C,5),7)
AND REF(O,7)>REF(MA(C,10),7);
F2:=H/REF(C,1)>=1.041;
XG6:=F1 AND F2;
TJ1:=MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20) AND OAND (REF(C,1)REF(MA(C,5),1) AND
REF(L,1)>REF(MA(C,20),1) AND O/REF(C,1)O;
HXG1:=(XG2 OR XG3 OR XG4 OR XG5 OR XG6)AND TJ1;
TCD1:=MA(C,5)>MA(C,20) AND MA(C,5)>MA(C,10);
WUJQ1:=HXG1 AND TCD1;
ZHW1:=WUJQ1 AND BARSCOUNT(C)ZHW2:=WUJQ1 AND MA(C,5)>MA(C,60) AND MA(C,5)>MA(C,120) AND MA(C,10)>MA(C,30) AND MA(C,10)>MA(C,60)AND MA(C,10)>MA(C,120);
WUJQ:=ZHW1 OR ZHW2;
STICKLINE(WUJQ,O,C,2.5,0),COLORYELLOW;{阳线}
DRAWICON(WUJQ,L*0.97,23);
VAR1:=MA((HIGH+LOW+2*CLOSE)/4,5);
VAR2:=EMA(VAR1,10)-EMA(VAR1,30);
VAR3:=EMA(VAR2,5);
VAR4:=(VAR2-VAR3)*5;
VAR5:=IF(VAR4动向:= FORCAST(FORCAST(VAR5,10),10);
趋势:=IF(VAR5>动向,VAR5,VAR1);
强势:=MA(VAR1,5);
弱势:=MA(HHV(VAR1,10),5);
主力:=SMA(CLOSE,10,1);
V61:=CLOSE/REF(CLOSE,1)>=1.1;
V71:=BACKSET(V61,1);
慧眼:=IF((V71 AND COUNT(V71,1)=1),30,0);

标签:

相关文章