大智慧公式股价分割位预测未来股票价格主图指标公式
01/23/2020

下面就是《大智慧股价分割位预测未来股票价格主图指标公式》的代码的,这是由股票公式指标网收集提供的,查看更多大智慧公式请你访问http://gupiao.qzjlw.com/category/dzhgs/

N:=5;
BU:=BARSLAST(CLOSE=HHV(CLOSE,N));
SE:=BARSLAST(CLOSE=LLV(CLOSE,N));
KK1:=SE;
KK2:=BU;
LM1:=SE;
LM2:=BU;
OK:=KK1>KK2 AND LM1>LM2;
OK1:=KK1>KK2 AND LM1<LM2;
NOK:=KK2>KK1 AND LM2>LM1;
NOK1:=KK2>KK1 AND LM2<LM1;
STICKLINE(OK1,CLOSE,OPEN,8,1),colorcyan;
STICKLINE(OK1,HIGH,LOW,0,0),colorcyan;
STICKLINE(OK,CLOSE,OPEN,8,1),color0000FF;
STICKLINE(OK,HIGH,LOW,0,0),color0000FF;
STICKLINE(NOK,CLOSE,OPEN,8,1),colorcyan;
STICKLINE(NOK,HIGH,LOW,0,0),colorcyan;
STICKLINE(NOK1,CLOSE,OPEN,8,1),color0000FF;
STICKLINE(NOK1,HIGH,LOW,0,0),color0000FF;
drawtext(CROSS(KK1,KK2),l*0.98,'B'),coloryellow,ALIGN1,LINETHICK3;
drawTEXT(CROSS(KK2,KK1),h*1.02,'S'),colorcyan,ALIGN1,valign2,LINETHICK3;
M1:WMA(CLOSE,14),LINETHICK2,color0000FF;
M2:=WMA(M1,5);
M3:IF(M1>M2,M2,M1),LINETHICK2,color00FF00;
M2,LINETHICK2,color000001;
X:=EMA(SLOPE(CLOSE,21)*20+CLOSE,68);
Y:=EMA(CLOSE,10);
LL:=REF(CLOSE,2);
MM:=(SMA(MAX(CLOSE-LL,0),6,1))/(SMA(ABS(CLOSE-LL),6,1))*100;
DB:=IF(MM<REF(MM,1) AND MM>79,MM,0);
{开盘后预测今日股价高低}
F:=(ref(high,1)+ref(low,1)+2*ref(close,1))/4;
今日次高:=2*F-ref(LOW,1);
今日次低:=2*F-ref(HIGH,1);
今日最高:=F+ref(HIGH,1)-ref(LOW,1);
今日最低:=F-(ref(HIGH,1)-ref(LOW,1));
DRAWTEXTabs(10,0,'●今日开盘股价预测,仅供参考'),colorFFBBCC;
DRAWTEXTabs(10,15,'●最高=:'+NUMTOSTR(今日最高)+''),colorFF00FF;
DRAWTEXTabs(10,30,'■次高=:'+NUMTOSTR(今日次高)+''),color0000FF;
DRAWTEXTabs(10,45,'■分割位=:'+NUMTOSTR(F)+''),color00FFFF;
DRAWTEXTabs(10,60,'■次低=:'+NUMTOSTR(今日次低)+''),colorcyan;
DRAWTEXTabs(10,75,'●最低=:'+NUMTOSTR(今日最低)+''),color00FF00;
{薛斯通道}
AHC1:=CLOSE*VOL;
AHC2:=EMA((EMA(AHC1,3)/EMA(VOL,3)+EMA(AHC1,6)/EMA(VOL,6)+EMA(AHC1,12)/EMA(VOL,12)+EMA(AHC1,24)/EMA(VOL,24))/4,13);
SUP:1.06*AHC2;
SDN:AHC2*0.94;
AHC3:=EMA(CLOSE,9);
LUP:EMA(AHC3*1.14,5);
LDN:EMA(AHC3*0.86,5);
DRAWTEXT( BARSTATUS=2,SUP,'-短上通道'),COLORf0fFF0;
DRAWTEXT( BARSTATUS=2,SDN,'-短下通道'),COLORf0f000;
DRAWTEXT( BARSTATUS=2,LUP,'-长上通道'),COLORf0f000;
DRAWTEXT( BARSTATUS=2,LDN,'-长下通道'),COLORf0f000;

标签:

相关文章